Our Lever integration is currently experiencing issues.
Incident Report for Drafted
Resolved
Lever has resolved the issue. The integration is now fully functional.
Posted Mar 11, 2020 - 17:09 EDT
Investigating
Lever is having issues with their API. You can follow the status here @ https://status.lever.co/
Posted Mar 11, 2020 - 14:41 EDT
This incident affected: Web Application.